Symptoms |
When creating a new cluster for Always-On SQL SERVER configuration. Fetching database button provides the below error:
Unable to fetch database server(s) with these settings (<VNNIP>:<PORT>)
Cause |
ScaleArc runs serveral queries during against the server that is provided as the VNN to discover the configuration options for the Availability Groups within the Always-On setup.
One of these queries is:
select * from sys.dm_hadr_instance_node_map
This query can have an empty result set if there are any orphaned (deleted) Availability Groups listing within the registry on the server that is currently running the VNN. (Although all members of the AG should be checked for the same registry entry.)
Solution |
Launch regedit on the SQL Server.
Browse to HKEY_LOCAL_MACHING\CLUSTER\HadrAgNameToldMap
Backup the registry key
Remove any orphaned records
Then verify that running the query select * from sys.dm_hadr_instance_node_map returns results.
If rows returned exceed 0 please recreate the cluster within ScaleArc.
Comments
0 comments
Please sign in to leave a comment.