Overview
This article provides the root cause and solution when the process to upload a new license file to the ScaleArc appliance fails with the error: "Unable to upload license file".
Prerequisites
- Environment: ScaleArc - all versions
- Access to the ScaleArc appliance via SSH
- Credentials for the
idb
user
Diagnosis
A ScaleArc administrator may be presented with the following error while uploading a new license file after the installed license has expired or during a fresh installation process. License upload is done through the UI by navigating to SETTINGS > License Settings then clicking on the Upload License button.
The above error occurs when large files such as debug logs are using up all available disk space in the ScaleArc appliance.
Solution
- Log in to a ScaleArc SSH session with idb user.
-
Run
df -h
command;- Look out for partitions with 100% utilization use and 0 available
-
Use the
sudo du -h --max-depth=1 <directory>
command to drill down the file system structure in search of directories with large space utilization. -
Delete any old and unused logs found to free up disk space and then run the
df -h
command once more to confirm that all ScaleArc file systems are at <100% utilization. - Retry the License upload and verify that no other errors are reported.
Confirmation
You should see a ScaleArc notification confirming that the new license was successfully installed as well as an updated expiry date as shown below:
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